or, The Hitchhiker’s Guide to Fear and Loathing at a Public Library Reference Desk


Reference Question of the Week – 1/10/16

   January 16th, 2016 Brian Herzog

Chrome logo crackedMy library subscribes to OCLC's QuestionPoint service, which is a 24/7 chat reference resource our patrons can use anytime. We've had this for years, and it's been great - not only being able to offer patrons 24-hour assistance, but also the quality of the answers they get is just as good or better than they would have gotten from our staff.

Every month I total up our database usage stats, and also read the transcripts of the chat questions asked. Sometimes though, when the chat librarian can't answer the question for whatever reason, the chat librarian flags it as "followup by local library" and I'm notified by email that a patron needs more help.

One of these followup notification emails was waiting for me when I got to the library this past Monday morning, after a chat session on Sunday. I logged into QuestionPoint to see what the question was, and found,

Chat transcript of patron saying a PDF on our website is blank

I had just put up the blog post in question the previous week, with the link to the contest application. I didn't have an electronic copy of the application, so I had to scan one of the print forms and make my own PDF.

So I was surprised to read the patron say it didn't work, because I remember opening it to double-check the margins of the scan looked okay.

Knowing that it worked, and thinking the patron must just be doing something wrong, I kept reading the chat transcript - confident that the chat librarian would have my back and set the patron right. But then this happened...

Chat librarian saying the PDF is blank for her too

What? Well, maybe something was actually wrong, if the chat librarian was seeing a blank page too.

So of course, I immediately go to the blog post and try the link again - and sure enough, it works just fine. So, I create a new PDF of the form, and email it directly to the patron (email is included in the chat transcript), apologizing for the problem and asking him to let me know if this one doesn't work.

The patron emailed back to say thanks, and a little more. After getting my message saying that it worked for me, the patron kept experimenting with the PDF link, and explained what he found:

Hi Brian.

OK - here's the scoop in case you get any others with this issue. This looks like a Google Chrome browser issue, and it may be unique to my computer, perhaps a settings problem. The PDF document opens fine in IE, Firefox, and Edge. It even opens fine in Chrome if I save the file first. But when I try to link to the file via the web it opens but with blank content. [...]

Thanks again for your follow up. I hope I haven't wasted too much of your time.

Wasted my time? You just did my job for me!

I'm glad it worked for him, but I was curious to see if this issue was just this one patron, or a Chrome thing. A quick search for Chrome blank PDF turned up a lot of relevant results, including some on Google forums. It seems like this is indeed a Chrome problem. And not exactly a new one at that, so I'm surprised that this is the first I was encountering it.

It also explains why the chat librarian had the same issue, while everything worked fine for me in Firefox.

It's not very often that I outsource my job, but in this one instance, I outsourced it twice - first to the chat librarian, and second to the patron.



Tags: , , , , , , , , ,